Project

General

Profile

Bug #15023

Errata applied but still shown as installable?

Added by Oliver Weinmann about 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hi,

I managed to get CentOS errata in Katello using the script provided here:

https://github.com/brdude/pulp_centos_errata_import

I had to adjust it a little bit to work with katello 2.4.

Errata is displayed in Katello. When appying the errata to a centos 6.7 or 7.2 host the packages are installed but katello still shows them as installable. Is this a known bug?

I'm running Katello 2.4.1 and Foreman 1.10.3

History

#1 Updated by Oliver Weinmann about 6 years ago

Workaround: Running the following 3 commands on the clients clears the installable errata:

subscription-manager refresh
katello-package-upload
service goferd restart

But still this should be done automatically...

#2 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 144

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 168 to 171

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (171)

#6 Updated by Justin Sherrill almost 6 years ago

  • Status changed from New to Need more information

was goferd running at the time after the package install occured?

any errors in /var/log/message on the client?

Can you narrow the 'fix' down one of those 3 commands? That might help us isolate where the issue is.

Thanks

#7 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

#8 Updated by Justin Sherrill almost 6 years ago

  • Status changed from Need more information to Rejected

Also available in: Atom PDF