Project

General

Profile

Bug #15026

The selected errata count for content hosts can show negative selected

Added by Walden Raines over 3 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1205232
Description of problem:
If you're at content hosts and then errata, you can get that to show a negative value selected.

Version-Release number of selected component (if applicable):
6.0.8

How reproducible:
100%

Steps to Reproduce:
1. Go to Content Hosts
2. Click the Errata tab
3. Select a few of the applicable errata
4. Click any of the the Id in the column
5. On that new page, click Back To Errata List

Actual results:
That takes you back to the errata page, but it shows 0 Selected even though you'll have those errata selected that you picked in step 4 from above.
When you unselect them, the 0 selected value goes down by one for each errata you unselect: -1 Selected, -2 Selected, ...

Expected results:
When you click that "Back To Errata List" link from step 5 and it takes you back, it should know however many are selected. You could wipe out any selections and always set it to 0 selected, but I think it'd be better to have the number selected be correct for what the customer had selected before.

Additional info:
In the attached screen shot, you can see that I have two errata selected but it shows -3 Selected. This is because I had five selected, clicked one of those RHEA or RHBA links, then clicked Back To Errata List then unselected three of those five that I had selected.


Related issues

Related to Katello - Tracker #16726: Bugs that will be fixed by removing nutupaneClosed2016-09-28

Related to Bastion - Bug #15027: The selected errata count for content hosts can show negative selectedClosed2016-05-12

History

#1 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

#2 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 143 to 114

#3 Updated by Walden Raines almost 3 years ago

  • Related to Tracker #16726: Bugs that will be fixed by removing nutupane added

#4 Updated by Walden Raines almost 3 years ago

  • Status changed from New to Duplicate

Duplicate of issue #15027

#5 Updated by Walden Raines almost 3 years ago

  • Related to Bug #15027: The selected errata count for content hosts can show negative selected added

Also available in: Atom PDF