Project

General

Profile

Bug #15053

ActiveRecord::StatementInvalid in Users#edit for non-admin user with all roles

Added by Andrew Kofink over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Dashboard
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1336146
Description of problem:
An ActiveRecord::StatementInvalid is thrown when a non-admin user with all RBAC roles assigned logs in.

Version-Release number of selected component (if applicable):
satellite-6.2.0-11.0

How reproducible:
Always

Steps to Reproduce:
1. Log in as an admin user
2. Create a new user
2a. Assign the new user all the roles
3. Logout and log in as the new user

Actual results:
ActiveRecord::StatementInvalid in Users#edit
https://paste.fedoraproject.org/366171/46316878/

Expected results:
The main dashboard is successfully rendered.

Additional info:

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3529 added

#2 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

#3 Updated by Justin Sherrill over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 143 to 114

#4 Updated by Andrew Kofink over 3 years ago

  • Status changed from Ready For Testing to Closed

Closing this as the issue is no longer able to be reproduced.

Also available in: Atom PDF