Project

General

Profile

Refactor #15060

Support activerecord-session_store 1.x

Added by Dominic Cleal over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

activerecord-session_store 1.x is out with a warning fixed for Ruby 2.3 and Rails 5 support. It's compatible with Rails 4.2, so just needs permitting.

https://github.com/rails/activerecord-session_store/releases/tag/v1.0.0


Related issues

Related to Foreman - Refactor #14840: Support Ruby 2.3Closed2016-04-26
Related to Foreman - Refactor #20960: Use activerecord-session_store with Rails 5.1 compatibility Closed2017-09-16

Associated revisions

Revision 12797719 (diff)
Added by Dominic Cleal over 4 years ago

fixes #15060 - permit activerecord-session_store 1.x

Revision 108561e3 (diff)
Added by Dominic Cleal over 4 years ago

refs #15060 - permit activerecord-session_store 1.x

History

#1 Updated by Dominic Cleal over 4 years ago

  • Tracker changed from Bug to Refactor

#2 Updated by The Foreman Bot over 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3531 added

#3 Updated by Dominic Cleal over 4 years ago

#4 Updated by Dominic Cleal over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 136

#6 Updated by Anonymous about 3 years ago

  • Related to Refactor #20960: Use activerecord-session_store with Rails 5.1 compatibility added

Also available in: Atom PDF