Project

General

Profile

Bug #15102

Unable to edit/create filters for user roles in 3.0RC4

Added by Dylan Baars about 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Roles and Permissions
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

If I browse to Administer > Roles, click "Filters" (on any role) > and click either "New Filter" or "Edit" an existing filter, I get the following error in the GUI

Oops, we're sorry but something went wrong ERF42-5434 [Foreman::Exception]: unknown permission view_taxonomies

I have attached the full trace from the webpage and the production.log output

full_trace.txt full_trace.txt 24.8 KB Dylan Baars, 05/19/2016 06:55 PM
production.log.output.txt production.log.output.txt 158 KB Dylan Baars, 05/19/2016 06:55 PM
full trace.txt full trace.txt 24.7 KB Dylan Baars, 05/25/2016 08:51 PM
production.log production.log 158 KB Dylan Baars, 05/25/2016 08:51 PM

Related issues

Is duplicate of Foreman - Bug #16204: NameError: uninitialized constant ExternalUsergroupsClosed2016-08-19

History

#1 Updated by Eric Helms almost 6 years ago

  • Category set to Roles and Permissions
  • Status changed from New to Need more information
  • Legacy Backlogs Release (now unused) changed from 86 to 144

I tried to reproduce this and didn't hit your error. Do you still hit this with RC5?

#2 Updated by Dylan Baars almost 6 years ago

Eric Helms wrote:

I tried to reproduce this and didn't hit your error. Do you still hit this with RC5?

I do - example in RC5, browsed to administer > roles > under actions for 'boot disk access' (as an example, seems to do it for all) "Add filter"

"Oops, we're sorry but something went wrong ERF42-5434 [Foreman::Exception]: unknown permission view_taxonomies"

production.log and full trace from the webpage attached again :-)

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 168 to 171

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (171)

#6 Updated by Justin Sherrill almost 6 years ago

Are you still seeing this issue?

If so, could you upload the output of:

foreman-rake console
Permission.pluck(:name)

#7 Updated by Dylan Baars almost 6 years ago

Yes still seeing it - Katello 3.0, which is running foreman 1.11.3

Output below:

[root@wellkatello scenarios.d]# foreman-rake console
/usr/share/foreman/lib/tasks/console.rake:6: warning: already initialized constant ARGV
Loading production environment (Rails 4.1.5)
irb(main):001:0> Permission.pluck(:name)
=> ["view_architectures", "create_architectures", "edit_architectures", "destroy_architectures", "view_audit_logs", "view_authenticators", "create_authenticators", "edit_authenticators", "destroy_authenticators", "view_bookmarks", "create_bookmarks", "edit_bookmarks", "destroy_bookmarks", "view_compute_profiles", "create_compute_profiles", "edit_compute_profiles", "destroy_compute_profiles", "view_compute_resources", "create_compute_resources", "edit_compute_resources", "destroy_compute_resources", "view_compute_resources_vms", "create_compute_resources_vms", "edit_compute_resources_vms", "destroy_compute_resources_vms", "power_compute_resources_vms", "console_compute_resources_vms", "view_provisioning_templates", "create_provisioning_templates", "edit_provisioning_templates", "destroy_provisioning_templates", "deploy_provisioning_templates", "lock_provisioning_templates", "view_config_groups", "create_config_groups", "edit_config_groups", "destroy_config_groups", "access_dashboard", "view_domains", "create_domains", "edit_domains", "destroy_domains", "view_environments", "create_environments", "edit_environments", "destroy_environments", "import_environments", "view_external_usergroups", "create_external_usergroups", "edit_external_usergroups", "destroy_external_usergroups", "view_external_variables", "create_external_variables", "edit_external_variables", "destroy_external_variables", "view_facts", "upload_facts", "view_filters", "create_filters", "edit_filters", "destroy_filters", "view_globals", "create_globals", "edit_globals", "destroy_globals", "edit_classes", "create_params", "edit_params", "destroy_params", "view_hostgroups", "create_hostgroups", "edit_hostgroups", "destroy_hostgroups", "view_hosts", "create_hosts", "edit_hosts", "destroy_hosts", "build_hosts", "power_hosts", "console_hosts", "ipmi_boot", "puppetrun_hosts", "view_images", "create_images", "edit_images", "destroy_images", "view_locations", "create_locations", "edit_locations", "destroy_locations", "assign_locations", "view_mail_notifications", "view_media", "create_media", "edit_media", "destroy_media", "view_models", "create_models", "edit_models", "destroy_models", "view_operatingsystems", "create_operatingsystems", "edit_operatingsystems", "destroy_operatingsystems", "view_organizations", "create_organizations", "edit_organizations", "destroy_organizations", "assign_organizations", "view_ptables", "create_ptables", "edit_ptables", "destroy_ptables", "lock_ptables", "view_plugins", "view_puppetclasses", "create_puppetclasses", "edit_puppetclasses", "destroy_puppetclasses", "import_puppetclasses", "view_realms", "create_realms", "edit_realms", "destroy_realms", "view_reports", "destroy_reports", "upload_reports", "view_roles", "create_roles", "edit_roles", "destroy_roles", "access_settings", "view_smart_proxies", "create_smart_proxies", "edit_smart_proxies", "destroy_smart_proxies", "view_smart_proxies_autosign", "create_smart_proxies_autosign", "destroy_smart_proxies_autosign", "view_smart_proxies_puppetca", "edit_smart_proxies_puppetca", "destroy_smart_proxies_puppetca", "view_statistics", "view_subnets", "create_subnets", "edit_subnets", "destroy_subnets", "import_subnets", "view_tasks", "view_trends", "create_trends", "edit_trends", "destroy_trends", "update_trends", "view_usergroups", "create_usergroups", "edit_usergroups", "destroy_usergroups", "view_users", "create_users", "edit_users", "destroy_users", "view_containers", "commit_containers", "create_containers", "destroy_containers", "view_registries", "create_registries", "destroy_registries", "search_repository_image_search", "view_foreman_tasks", "edit_foreman_tasks", "view_activation_keys", "create_activation_keys", "edit_activation_keys", "destroy_activation_keys", "manage_capsule_content", "view_content_hosts", "create_content_hosts", "edit_content_hosts", "destroy_content_hosts", "view_content_views", "create_content_views", "edit_content_views", "destroy_content_views", "publish_content_views", "promote_or_remove_content_views", "view_gpg_keys", "create_gpg_keys", "edit_gpg_keys", "destroy_gpg_keys", "view_host_collections", "create_host_collections", "edit_host_collections", "destroy_host_collections", "view_lifecycle_environments", "create_lifecycle_environments", "edit_lifecycle_environments", "view_capsule_content", "destroy_lifecycle_environments", "promote_or_remove_content_views_to_environments", "view_products", "create_products", "edit_products", "destroy_products", "sync_products", "view_subscriptions", "attach_subscriptions", "unattach_subscriptions", "import_manifest", "delete_manifest", "view_sync_plans", "create_sync_plans", "edit_sync_plans", "destroy_sync_plans", "my_organizations", "download_bootdisk", "view_discovered_hosts", "submit_discovered_hosts", "auto_provision_discovered_hosts", "provision_discovered_hosts", "edit_discovered_hosts", "destroy_discovered_hosts", "view_discovery_rules", "create_discovery_rules", "edit_discovery_rules", "execute_discovery_rules", "destroy_discovery_rules", "create_recurring_logics", "view_recurring_logics", "edit_recurring_logics", "view_content_reports", "export_content_views", "export_products", "view_config_reports", "destroy_config_reports", "upload_config_reports"]
irb(main):002:0>

Justin Sherrill wrote:

Are you still seeing this issue?

#8 Updated by Justin Sherrill almost 6 years ago

  • Status changed from Need more information to New

#9 Updated by Justin Sherrill almost 6 years ago

Digging into this more, it is quite curious.

Can you run the following in a 'foreman-rake console':

  Location.try(:permission_name)
  Organization.try(:permission_name)
  Location.to_s
  Organization.to_s

#10 Updated by Justin Sherrill almost 6 years ago

  • Status changed from New to Need more information

#11 Updated by Dylan Baars almost 6 years ago

[root@wellkatello ~]# foreman-rake console
/usr/share/foreman/lib/tasks/console.rake:6: warning: already initialized constant ARGV
Loading production environment (Rails 4.1.5)
irb(main):001:0> Location.try(:permission_name)
=> nil
irb(main):002:0> Organization.try(:permission_name)
=> nil
irb(main):003:0> Location.to_s
=> "Location"
irb(main):004:0> Organization.to_s
=> "Organization"
irb(main):005:0>

Justin Sherrill wrote:

Digging into this more, it is quite curious.

Can you run the following in a 'foreman-rake console':
[...]

#12 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

#13 Updated by Justin Sherrill almost 6 years ago

  • Status changed from Need more information to Rejected

#14 Updated by Dylan Baars almost 6 years ago

Why has this been rejected? Have I not provided enough information?

#15 Updated by Chris Duryee over 5 years ago

  • Status changed from Rejected to New

I hit this as well, using the same repro steps as listed in the original ticket.

#16 Updated by Justin Sherrill over 5 years ago

  • Legacy Backlogs Release (now unused) deleted (166)

#17 Updated by Justin Sherrill over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Justin Sherrill

#18 Updated by Chris Duryee over 5 years ago

I get the following when attempting to repro on master:

2016-11-10 10:13:34 176bae4b [app] [W] unknown class ExternalUsergroups, ignoring
 | NameError: uninitialized constant ExternalUsergroups

This appears to not affect anything, but causes a large stacktrace in production.log

#20 Updated by Chris Duryee over 5 years ago

  • Related to Bug #16204: NameError: uninitialized constant ExternalUsergroups added

#21 Updated by Chris Duryee over 5 years ago

  • Bugzilla link set to 1399241

#22 Updated by Eric Helms over 5 years ago

  • Status changed from Assigned to Duplicate
  • Bugzilla link deleted (1399241)

#23 Updated by Eric Helms over 5 years ago

  • Related to deleted (Bug #16204: NameError: uninitialized constant ExternalUsergroups)

#24 Updated by Eric Helms over 5 years ago

  • Is duplicate of Bug #16204: NameError: uninitialized constant ExternalUsergroups added

#25 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF