Project

General

Profile

Feature #15115

Filter datastore and network selection

Added by Angelo Lisco over 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When deploying a new host on a Vmware CR, the selection of the datastore/datastore cluster and the network should filter out the irrelevant objects for the chosen cluster.

When you have more then one cluster on your vmware datacenter and many different dvPortGroup and datastores, the actual form is really confusing. It can happen that one can try to deploy a new vm on a datastore or on a network that isn't available for that specify cluster.

I can see that list_datastore[1] and list_network[2] methods in the fog-vsphere library support a filtering option...so it should not be too difficult to implement what i'm asking.

[1] http://www.rubydoc.info/github/fog/fog/Fog/Compute/Vsphere/Real#list_datastores-instance_method
[2] http://www.rubydoc.info/github/fog/fog/Fog/Compute/Vsphere/Real#list_networks-instance_method


Related issues

Related to Foreman - Bug #19424: VMware provisioning displays all IP addressNew2017-04-28
Is duplicate of Foreman - Feature #2113: Better VMWare Datastore UIClosed

History

#1 Updated by Timo Goebel about 3 years ago

  • Is duplicate of Feature #2113: Better VMWare Datastore UI added

#2 Updated by Dominic Cleal about 3 years ago

  • Status changed from New to Duplicate

Thanks for the report, we're tracking this under #2113.

#3 Updated by Angelo Lisco about 3 years ago

Dominic Cleal wrote:

Thanks for the report, we're tracking this under #2113.

Whoops...i totally missed that!
Thanks Dominic

#4 Updated by Angelo Lisco about 3 years ago

Sorry for the noise, Dominic, but do you think I should open a new issue for Network UI as well? #2113 is only about datastore selection

#5 Updated by Dominic Cleal about 3 years ago

I'll let Timo decide, I don't know if he's planning to fix that inside the other ticket. If not then we can re-open and rename this for the network part. Thanks for checking.

#6 Updated by Angelo Lisco over 2 years ago

  • Related to Bug #19424: VMware provisioning displays all IP address added

Also available in: Atom PDF