Project

General

Profile

Bug #15137

Error notification stopped to show after going to the same page

Added by Ondřej Pražák over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1335799
Description of problem:
Notification error is shown correctly when I do wrong action on the page, but once I try to open the same page and do the same action, it stopped to show

Version-Release number of selected component (if applicable):
6.2 GA SNAP11

How reproducible:
Always

Steps to Reproduce:
1. Go to Settings page
2. Try to edit 'Entries per page' setting to invalid value (e.g. 'test')
3. Notification error is displayed. Close it
4. Go to Settings page once again
5. Try to edit same setting to the same value

Actual results:
Nothing happen, when I perform wrong action on the page

Expected results:
Notification error should be shown all the time

Additional info:


Related issues

Related to Foreman - Refactor #14178: Replace jnotify with patternfly toast notificationsClosed2016-03-14

Associated revisions

Revision 8ee0d81e (diff)
Added by Ondřej Pražák over 4 years ago

Fixes #15137 - Find correct jnotify container

jnotify creates message container on first use and caches it
internally. When using turbolinks, page body is swapped
but jnotify has no clue about the change and appends the
message to the old container which means no message is
displayed. Giva Labs (the author) provides
plugin zipped without any instructions for contributors
or reference to the repository, that is the reason I
chose to modify jnotify directly.

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3543 added

#2 Updated by Tomer Brisker over 4 years ago

  • Related to Refactor #14178: Replace jnotify with patternfly toast notifications added

#3 Updated by Ondřej Pražák over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 136

Also available in: Atom PDF