Project

General

Profile

Bug #15197

Duplicate entries for hypervisors after renaming content host

Added by Thomas McKay almost 3 years ago. Updated 9 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1340088
Description of problem:
After renaming the hypervisor in /content_hosts and another run of virt-who
the hypervisor content host is again created with a random name but with
the same uuid.

Version-Release number of selected component (if applicable):
Satellite 6.2 SNAP 13.1
virt-who 0.14-9.el7

How reproducible:
With every virt-who run

Steps to Reproduce:
1. Register hypervisor via virt-who
2. Rename hypervisor in /content_hosts
3. Run virt-who again

Actual results:
A new entry is created in /content_hosts

Expected results:
Only update the already existing content host

Additional info:
- virt-who is always sending the correct hypervisor uuid
- looks like the unique identifier was changed from the content hosts uuid to the name
- this is a regression as it worked fine in 6.1

Associated revisions

Revision 78bb525a (diff)
Added by Thomas McKay almost 3 years ago

fixes #15197 - find hypervisors by uuid before name

Revision c551fb34
Added by Thomas McKay almost 3 years ago

Merge pull request #6076 from thomasmckay/15197-hv-rename

fixes #15197 - find hypervisors by uuid before name

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Thomas McKay
  • Pull request https://github.com/Katello/katello/pull/6076 added

#2 Updated by Eric Helms almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

#3 Updated by Thomas McKay almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF