Project

General

Profile

Bug #15228

/config_reports fails when a config_reports filter search is limited.

Added by Steve Traylen almost 5 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Users, Roles and Permissions
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

With a config_report permission of for instance 'hostgroup_title ~ bi/% or hostgroup_title = bi'
the following URL fails.

/config_reports

Mysql2::Error: Unknown column 'hosts_reports.id' in 'field list': SELECT `reports`.`id` AS t0_r0, `reports`.

Giving the user admin permissions or unlimited permissions is enough to avoid the situation and the page renders.

Steve.

config_reports_productin.log config_reports_productin.log 35.5 KB production.log of /config_reports Steve Traylen, 05/30/2016 10:51 AM

Related issues

Is duplicate of Foreman - Bug #10819: PGError: ERROR: missing FROM-clause entry for table "hosts_reports" LINE 1New2015-06-15

History

#1 Updated by Shlomi Zadok almost 5 years ago

Does it get solved when giving a user "view_hosts" permission ?

#2 Updated by Dominic Cleal over 4 years ago

  • Is duplicate of Bug #10819: PGError: ERROR: missing FROM-clause entry for table "hosts_reports" LINE 1 added

#3 Updated by Dominic Cleal over 4 years ago

  • Status changed from New to Duplicate

Thanks for the report, I think this is the same bug as #10819 so we'll use that ticket to track the issue.

Also available in: Atom PDF