Project

General

Profile

Actions

Bug #15238

closed

Multiple interfaces with empty identifier are marked as invalid

Added by Marek Hulán about 8 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Network
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

The NIC validation is not treating empty identifier correctly. While the validation method on host skips such interfaces, validation on NIC side tries to enforce uniqueness even of empty identifiers. This causes problems during provisioning of host with multiple interfaces, preventing the TFTP change because of interface being invalid. To reproduce, create a host with two interfaces with empty identifier. Then try editing the host, e.g. changing the comment attribute. It fails on interface identifier being already taken.


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #12441: Duplicate entries in `nics` tableClosedBrandon Weeks11/10/2015Actions
Actions #1

Updated by Marek Hulán about 8 years ago

  • Related to Bug #12441: Duplicate entries in `nics` table added
Actions #2

Updated by The Foreman Bot about 8 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3560 added
Actions #3

Updated by Marek Hulán about 8 years ago

  • Translation missing: en.field_release set to 159

the bug was introduced in 1.11 so marking for next 1.11 release, feel free to reset

Actions #4

Updated by Marek Hulán about 8 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #5

Updated by Marek Hulán over 7 years ago

  • Bugzilla link set to 1406362
Actions

Also available in: Atom PDF