Project

General

Profile

Bug #15274

[Sat6] hammer content-view filter rule list shows only 20 entries

Added by Andrew Kofink almost 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1305055
Description of problem:

Trying to view the rules for a filter via hammer results
in showing only 20 entries.

--full-results appears to be unimplemented

Version-Release number of selected component (if applicable):

Sat 6.1.6

How reproducible:

100%

Steps to Reproduce:
- Create a content view filter with more than 20 entries
1. hammer --username=admin --password=<password> content-view filter create --organization=org-example --content-view='filter test' --name='test_filter' --inclusion=true --type=rpm
2. hammer --username=admin --password=<password> content-view filter rule create --organization=org-example --content-view='filter test' --content-view-filter='test_filter' --name a
3. Repeat the above until you have > 20
4. hammer --username=admin --password=<password> content-view filter rule list --organization=org-example --content-view='filter test' --content-view-filter='test_filter'

Actual results:

Only 20 rules are show

Expected results:

As the default across hammer seems to be 20 items per page,
we should implement `--full-results` so that all results
can be returned.

Additional info:

See also https://bugzilla.redhat.com/show_bug.cgi?id=1202050
which implemented this for `hammer content-view list` and
`hammer puppet-module list`

Same applies to filter list, there is no --full-results implemented


Related issues

Is duplicate of Hammer CLI - Bug #15257: Default per_page configuration enables pagination, including in CSV modeClosed2016-06-01

History

#1 Updated by The Foreman Bot almost 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6099 added

#2 Updated by Dominic Cleal almost 6 years ago

  • Project changed from Hammer CLI to Katello

#3 Updated by Andrew Kofink almost 6 years ago

  • Pull request deleted (https://github.com/Katello/katello/pull/6099)

#4 Updated by Andrew Kofink almost 6 years ago

  • Status changed from Ready For Testing to Assigned

#5 Updated by Andrew Kofink almost 6 years ago

  • Pull request https://github.com/theforeman/hammer-cli/pull/208 added

#6 Updated by Andrew Kofink almost 6 years ago

  • Pull request deleted (https://github.com/theforeman/hammer-cli/pull/208)

#7 Updated by Andrew Kofink almost 6 years ago

  • Is duplicate of Bug #15257: Default per_page configuration enables pagination, including in CSV mode added

#8 Updated by Andrew Kofink almost 6 years ago

  • Status changed from Assigned to Duplicate

#9 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF