Project

General

Profile

Bug #15289

host-collection content-base subcommand is nonexistant

Added by Andrew Kofink almost 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Hammer
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1335552
Description of problem: There is a subcommand in host_collection.rb named ContentBaseCommand with three actions, but there is no way to access them in hammer.

Version-Release number of selected component (if applicable):
6.2, 6.1, devel

How reproducible:
Always

Steps to Reproduce:
1. Run each hammer command below
hammer host-collection content-base install
hammer host-collection content-base update
hammer host-collection content-base remove

Actual results:
Error: No such sub-command 'content-base'

See: 'hammer host-collection --help'

Expected results:
Content installed
Content updated
Content removed

Additional info:
I believe this hammer subcommand should be calling the hosts_bulk_actions_controller in Katello's API.


Related issues

Related to Katello - Feature #11531: As a developer, the content hosts UI needs to utilize new v2 apis showing the list of content hostsClosed2015-08-24
Related to Katello - Feature #11508: As a user, bulk actions should be based off hosts instead of content hosts (4)Closed2015-08-24

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Project changed from Hammer CLI to Katello
  • Category set to Hammer

#2 Updated by Justin Sherrill almost 6 years ago

  • Priority changed from Normal to High
  • Legacy Backlogs Release (now unused) set to 144
  • Difficulty set to medium

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (144)

#4 Updated by Justin Sherrill almost 6 years ago

  • Priority changed from High to Low
  • Legacy Backlogs Release (now unused) set to 114

#5 Updated by Andrew Kofink almost 6 years ago

  • Related to Feature #11531: As a developer, the content hosts UI needs to utilize new v2 apis showing the list of content hosts added

#6 Updated by Andrew Kofink almost 6 years ago

  • Related to Feature #11508: As a user, bulk actions should be based off hosts instead of content hosts (4) added

#7 Updated by Andrew Kofink almost 6 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) changed from 114 to 166

There is no content-base command. This "command" is actually named this way because it is the base logic for the package, package group, and errata subcommands, which all exist. Because of this, I'm closing this.

Also available in: Atom PDF