Project

General

Profile

Bug #15294

"Reset Puppet Environment to match selected Content View" does not work in Satellite 6.2 BETA

Added by Partha Aji over 3 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1336802
Description of problem:

When creating a new Host in Satellite 6.2 BETA, one always needs to select the "Puppet Environment" because "Reset Puppet Environment to match selected Content View" does not work/set the Environment as expected respectively as done in Satellite 6.1.

It's also not possible to leave "Puppet Environment" blank and therefore simply inherit what was defined in the HostGroup. Since this was working on Satellite 6.1, customers are expecting this to work again.

Version-Release number of selected component (if applicable):

- foreman-1.11.0.24-1.el7sat.noarch
- katello-3.0.0-3.el7sat.noarch
- puppet-3.8.6-2.el7sat.noarch
- candlepin-0.9.54.5-1.el7.noarch

How reproducible:

Always

Steps to Reproduce:
1. Setup Satellite 6.2 BETA (I'm using SNAP 11)
2. Configure Satellite 6.2 BETA
3. Define new Host and use "Reset Puppet Environment to match selected Content View" for the selection of the "Puppet Environment"

Actual results:

No "Puppet Environment" defined

Expected results:

The "Puppet Environment" defined in the HostGroup should be selected and added to this host

Additional info:


Related issues

Is duplicate of Katello - Bug #15295: "Reset Puppet Environment to match selected Content View" does not workClosed2016-06-03

History

#1 Updated by David Davis over 3 years ago

  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by David Davis over 3 years ago

  • Is duplicate of Bug #15295: "Reset Puppet Environment to match selected Content View" does not work added

#3 Updated by David Davis over 3 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF