Project

General

Profile

Bug #15302

Ordering of certificate generation causes private key mismatch

Added by Dominic Cleal about 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Foreman modules
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

There's an intermittent issue on our Foreman/Puppet installation tests causing a private key/certificate mismatch across multiple OSes.

When running the agent after, it shows errors such as:

# (in test file /usr/bin/fb-puppet-tests.bats, line 94)
#   `puppet agent -v -o --no-daemonize' failed
# Error: Could not request certificate: The certificate retrieved from the master does not match the agent's private key.
# Certificate fingerprint: B8:19:7E:01:9A:03:3F:05:88:B0:B2:C5:D8:A8:3C:C9:9B:C7:0B:AF:21:E2:28:4F:EB:E8:4E:32:C4:A4:6D:B1
# To fix this, remove the certificate from both the master and the agent and then start a puppet run, which will automatically regenerate a certficate.
# On the master:
#   puppet cert clean foreman-el6.example.com
# On the agent:
#   1a. On most platforms: find /etc/puppetlabs/puppet/ssl -name foreman-el6.example.com.pem -delete
#   1b. On Windows: del "/etc/puppetlabs/puppet/ssl/foreman-el6.example.com.pem" /f
#   2. puppet agent -t
foreman-debug.tar.xz foreman-debug.tar.xz 128 KB jessie PC1 systest debug Dominic Cleal, 06/06/2016 07:14 AM
fb-install-foreman.bats.out fb-install-foreman.bats.out 365 KB jessie PC1 systest log Dominic Cleal, 06/06/2016 07:14 AM
foreman-debug.tar.xz foreman-debug.tar.xz 159 KB el6 nightly systest debug Dominic Cleal, 06/06/2016 07:15 AM
fb-install-foreman.bats.out fb-install-foreman.bats.out 428 KB el6 nightly systest log Dominic Cleal, 06/06/2016 07:15 AM

Related issues

Is duplicate of Installer - Bug #15550: SSL Certificate mismatch when installing with the installerClosed2016-06-30

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of Bug #15550: SSL Certificate mismatch when installing with the installer added

#2 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF