Project

General

Profile

Bug #15315

Capsule upgrade 6.1->6.2 snap 13 incorrectly resets trusted hosts and foreman-url

Added by Brad Buckingham over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1341756
Description of problem:
When upgrading a capsule from satellite 6.1 to satellite 6.2 beta (snap 13), running "satellite-installer --upgrade --scenario capsule ..." causes settings.yml to remove the satellite server from the trusted_hosts list and resets the foreman_url to the capsule's hostname instead of the server's hostname.

Version-Release number of selected component (if applicable):
6.2 Beta snap 13

How reproducible:

Steps to Reproduce:
1. satellite-installer --upgrade --scenario capsule
2.
3.

Actual results:
settings.yml contains the following settings:
trusted_hosts:
- <capsule hostname>

foreman_url: <capsule hostname>

Expected results:
settings.yml contains the following settings:
trusted_hosts:
- <capsule hostname>
- <satellite server hostname>

foreman_url: <satellite server hostname>

Additional info:

Associated revisions

Revision b2322b35 (diff)
Added by Brad Buckingham over 3 years ago

fixes #15315: add migration to update capsule configuration

This commit will migrate several additional fields
from the legacy capsule configuration (/etc/capsule-installer)
to the new configuration (/etc/foreman-installer/scenarios.d).

In addition, a change is being introduced to keep the
default log_dir and log_name from the new configurations
versus from the old (e.g. /v/l/capsule-installer). This
was the intended behavior and is what is used by some
downstreams.

Revision 00399e90
Added by Brad Buckingham over 3 years ago

Merge pull request #357 from bbuckingham/issue-15315

fixes #15315: update capsule foreman url & trusted hosts

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Brad Buckingham
  • Pull request https://github.com/Katello/katello-installer/pull/357 added

#2 Updated by Brad Buckingham over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by David Davis over 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

Also available in: Atom PDF