Project

General

Profile

Bug #15334

Subscription status is wrong on content host details > subscriptions tab

Added by John Mitsch almost 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Subscription status will show up as red with no text even when subscription status is yellow or green.

To reproduce:

1) Import a manifest with valid subs
2) Register a RHEL content host
3) run subscription-manager attach --auto on the content host
4) check the content host details page > subscription tab for that content host

It should be yellow or green with the valid corresponding text, not red

Associated revisions

Revision 3c040d05 (diff)
Added by John Mitsch almost 3 years ago

Fixes #15334 - Sub status updates correctly in CH details page (#6107)

To reproduce:

1) Import a manifest with valid subs
2) Register a RHEL content host
3) run subscription-manager attach --auto on the content host
4) check the content host details page > subscription tab for that
content host

On this page, the subscription status should be yellow or green,
not red. The correct text should be next to the color.

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to John Mitsch
  • Pull request https://github.com/Katello/katello/pull/6107 added

#2 Updated by John Mitsch almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by David Davis almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

Also available in: Atom PDF