Project

General

Profile

Bug #15339

Upgrade from Katello 3.0 RC5 to latest RC mongod "failed to call refresh"

Added by Dylan Baars about 5 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

[root@wellkatellodev ~]# foreman-installer --scenario katello --upgrade
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_databases...
Upgrade Step: update_http_conf...
Upgrade Step: migrate_pulp...
Upgrade Step: fix_pulp_httpd_conf...
Upgrade Step: start_httpd...
Upgrade Step: start_qpidd...
Upgrade Step: start_pulp...
Upgrade Step: migrate_candlepin...
Upgrade Step: start_tomcat...
Upgrade Step: fix_katello_settings_file...
Upgrade Step: migrate_foreman...
Upgrade Step: remove_nodes_distributors...
Upgrade Step: Running installer...
/Stage[main]/Mongodb::Server::Service/Service[mongodb]: Failed to call refresh: Could not restart Service[mongodb]: Execution of '/usr/share/katello-installer-base/modules/service_wait/bin/service-wait restart mongod' returned 7: Redirecting to /bin/systemctl restart mongod.service
/Stage[main]/Mongodb::Server::Service/Service[mongodb]: Could not restart Service[mongodb]: Execution of '/usr/share/katello-installer-base/modules/service_wait/bin/service-wait restart mongod' returned 7: Redirecting to /bin/systemctl restart mongod.service
Could not prefetch mongodb_user provider 'mongodb': Could not evalute MongoDB shell command: printjson(db.system.users.find().toArray())
Installing Done [100%] [.........................................................................................................................................................]
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/foreman-installer/katello.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: import_package_groups (this may take a while) ...
Upgrade Step: import_rpms (this may take a while) ...
Upgrade Step: import_distributions (this may take a while) ...
Upgrade Step: import_puppet_modules (this may take a while) ...
Upgrade Step: import_subscriptions (this may take a while) ...
Upgrade Step: elasticsearch_message...
Upgrade Step: remove_docker_v1_content (this may take a while) ...
Upgrade Step: remove_gutterball...
[root@wellkatellodev ~]#

katello version (as reported in the GUI > Administer > About) to be katello-3.0.0-8.rc8.el7.noarch

I have attached the katello.log installer log

The mongod service is running post upgrade

[root@wellkatellodev ~]# systemctl status mongod
● mongod.service - High-performance, schema-free document-oriented database
Loaded: loaded (/usr/lib/systemd/system/mongod.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2016-06-08 10:03:44 NZST; 18min ago
Process: 15192 ExecStart=/usr/bin/mongod $OPTIONS run (code=exited, status=0/SUCCESS)
Main PID: 15194 (mongod)
CGroup: /system.slice/mongod.service
└─15194 /usr/bin/mongod --quiet -f /etc/mongod.conf run

Jun 08 10:03:44 wellkatellodev.niwa.local systemd1: Starting High-performance, schema-free document-oriented database...
Jun 08 10:03:44 wellkatellodev.niwa.local mongod15192: about to fork child process, waiting until server is ready for connections.
Jun 08 10:03:44 wellkatellodev.niwa.local mongod15192: forked process: 15194
Jun 08 10:03:44 wellkatellodev.niwa.local mongod15192: child process started successfully, parent exiting
Jun 08 10:03:44 wellkatellodev.niwa.local systemd1: Started High-performance, schema-free document-oriented database.
[root@wellkatellodev ~]#

katello.log katello.log 1020 KB Dylan Baars, 06/07/2016 06:22 PM

Related issues

Is duplicate of Katello - Bug #15326: Revert mongo authenticationClosed2016-06-07

History

#1 Updated by Eric Helms about 5 years ago

  • Status changed from New to Duplicate

#2 Updated by Eric Helms about 5 years ago

  • Is duplicate of Bug #15326: Revert mongo authentication added

Also available in: Atom PDF