Project

General

Profile

Bug #15347

Activation Key returning all systems under associations tab

Added by John Mitsch almost 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

To reproduce:

Register at least one host (or content host). Create an activation key and check the content host associations tab in that activation key

Expected Results:

Only the hosts associated with the activation key show in the activation key > associations tab

Actual Results:

All of the hosts show in the activation key > associations tab

Associated revisions

Revision 515a48bf (diff)
Added by John Mitsch almost 3 years ago

Fixes #15347 - Filter hosts for activation key associations (#6113)

All systems are being returned in the activation key associations page.
This changes that page to use hosts endpoint instead of activation keys,
which makes it possible to use scoped search to filter them.

History

#1 Updated by John Mitsch almost 3 years ago

  • Bugzilla link set to 1344033

#2 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 143
  • Difficulty set to easy

#3 Updated by John Mitsch almost 3 years ago

  • Legacy Backlogs Release (now unused) deleted (143)
  • Difficulty deleted (easy)
  • Bugzilla link deleted (1344033)

Note that the status icons are incorrect on this page as well and can be fixed with this change. The are also incorrect in the subscription associations page

#4 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6113 added

#5 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

#6 Updated by John Mitsch almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Pavel Moravec over 2 years ago

Bugzilla link: https://bugzilla.redhat.com/show_bug.cgi?id=1372826

(seems I cant edit/set it directly in the issue header)

#8 Updated by Chris Roberts over 2 years ago

  • Bugzilla link set to 1372826

Also available in: Atom PDF