Project

General

Profile

Bug #15389

errata page broken

Added by Chris Duryee over 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The errata page is currently broken. To reproduce, just go to "errata" from the content menu in the top nav bar.

This is related to a SQL fix from http://projects.theforeman.org/issues/15253.

Associated revisions

Revision 42502063 (diff)
Added by Chris Duryee over 2 years ago

Fixes #15389 - errata page is broken

There was a SQL optimization done in PR #6094 which made the dashboard
faster, but interfered with some other callers of the errata model obj.
Basically, the optmized SQL had a `DISTINCT` baked in, so if you called
`uniq` on the results, you'd get an error since you'd have two
`DISTINCT`s.

It turns out that there was an extra inner join, which created a very
large dataset for postgres to work on. For example, 5.5K hosts with 650
errata may create a dataset of upwards of 84M records. This would
exhaust system resources quickly.

This commit removes the extra inner join, and removes the opimization
in #6094 since its no longer needed.

Revision 078802df
Added by Chris Duryee over 2 years ago

Merge pull request #6117 from beav/sql-fix2

Fixes #15389 - errata page is broken

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6117 added

#2 Updated by Chris Duryee over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 143

Also available in: Atom PDF