Project

General

Profile

Bug #15394

Available pool quantity is wrong after removed subscribed pool(by virt-who)

Added by John Mitsch almost 3 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1339481
Description of problem:
After removed subscribed pool, it can't add the removed pools to available list.

Version-Release number of selected component (if applicable):
Satellite-6.2.0-RHEL-7-20160518
virt-who-0.17-1.el7.noarch
subscription-manager-1.17.6-1.el7.x86_64
python-rhsm-1.17.2-1.el7.x86_64

How reproducible:

Steps to Reproduce:
1. Register host to satellite
2. Open satellite webUI, subscribe and check available pool of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)"as the following:

go to Hosts-->Content hosts, click on host, jump to host detail page, go to Subscriptions-->Add, it will show the available pool quantity of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)" under "Attach" tab is "0 out of 50"(see attachment "before attach"), click on "Add Selected", it will subscribe two pools.

3. In webUI, check the quantity of available pool of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)" is "2 out of 50"(see attachment "after attach")
4. In webUI, Remove the subscribed pool on step2
5. Check the quantity of available pool of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)"

Actual results:
It still show "2 out of 50"(see attachment "after remove")

Expected results:
It should show "0 out of 50" since it hasn't been subscribed by any host.

Additional info:

Associated revisions

Revision e2875646 (diff)
Added by John Mitsch almost 3 years ago

Fixes #15394 - quantity updates after subs are removed from host (#6119)

When removing subscriptions from a host, the subscription quanities
now update so that the quantity for that subscription/pool will be
correct.

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to John Mitsch
  • Pull request https://github.com/Katello/katello/pull/6119 added

#2 Updated by John Mitsch almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

Also available in: Atom PDF