Project

General

Profile

Bug #15470

Upgrade from 2.4 to 3.0 lost my foreman-ipa-authentication setting

Added by Leah Fisher almost 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

After upgrading to Katello 3.0/Foreman 1.11 I was unable to log in using my ipa credentials. After searching, I found that the --foreman-ipa-authentication was set to false. Running the installer with this set to true solved my issues.

History

#1 Updated by Eric Helms almost 6 years ago

  • Status changed from New to Need more information

Leah,

When you did your upgrade, did you have rubygem-kafo-0.7.4 installed?

#2 Updated by Leah Fisher almost 6 years ago

When I ran yum update, it wasn't in the packages, but I installed it manually before I ran the foreman-installer --upgrade command.

#3 Updated by Justin Sherrill almost 6 years ago

  • Category set to Installer
  • Legacy Backlogs Release (now unused) set to 171
  • Difficulty set to medium

#4 Updated by Justin Sherrill almost 5 years ago

  • Legacy Backlogs Release (now unused) deleted (171)

#5 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

#6 Updated by Justin Sherrill almost 5 years ago

  • Status changed from Need more information to Rejected

The upgrade process has improved greatly since 3.0 and we do not believe this is an issue any more. Please reopen if someone hits this again. Thanks!

Also available in: Atom PDF