Project

General

Profile

Bug #15486

PUT /api/v2/host_collections/ do not return 'host_ids' attribute

Added by Brad Buckingham over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When updating (PUT) a host collection via the API, the API does not return the host_ids attribute. In addition, if the host_ids are passed in empty, they host collection is not getting updated properly.

This issue is related to http://projects.theforeman.org/issues/14712 ; therefore, refer to it for further details.

Associated revisions

Revision 15c1a2eb (diff)
Added by Brad Buckingham over 3 years ago

fixes #15486: API: include host_ids in update response (PUT)

This commit will ensure the following during an update (PUT):
1. include host_ids in the update response
2. update host_ids to [], if an empty list is provided

Revision a6b6d64c
Added by Brad Buckingham over 3 years ago

Merge pull request #6141 from bbuckingham/issue-15486

fixes #15486: API: include host_ids in update response (PUT)

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6141 added

#2 Updated by Brad Buckingham over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill over 3 years ago

  • Legacy Backlogs Release (now unused) set to 168

Also available in: Atom PDF