Project

General

Profile

Bug #15516

enabling an ostree repository causes error on manifest refresh actions

Added by Thomas McKay over 4 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Since the ostree repos are not available on the cdn yet, enabling them in the OSTree tab of the Red Hat Repositories page will (properly) show an error. However, some part of them has been partially created in pulp which causes error when user attempts to refresh manifest.

In glue/pulp/repo.rb the lazy_accessor :importers will error on manifest refresh.

The OSTree repo will show up as enabled in the UI but errors when trying to disable it.

My suggestion would be to make sure that the initial enable is fully rolled back on an error.


Related issues

Is duplicate of Katello - Bug #15824: Enabling a repository needs to fail on pulp errorClosed2016-07-24

History

#1 Updated by Thomas McKay over 4 years ago

  • Bugzilla link set to 1349862

#2 Updated by Justin Sherrill over 4 years ago

  • Is duplicate of Bug #15824: Enabling a repository needs to fail on pulp error added

#3 Updated by Justin Sherrill over 4 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF