Project

General

Profile

Feature #15536

[Sat6] allow multiple rpms to be added via content-view filter rule create API endpoint

Added by Andrew Kofink almost 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
API
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1305059
Description of problem:

The `hammer content-view filter rule create` command can only handle
one rpm name at a time.

Version-Release number of selected component (if applicable):

6.1.6

How reproducible:

100%

Steps to Reproduce:
1. Create an rpm include content view filter.

2. Attempt to add 2 packages at once
  1. hammer --username=admin --password=<password> content-view filter rule create --organization=org-example --content-view='filter test' --content-view-filter='test_filter' --name c --name d

Will only add package "d" to the included rpms

3. Attempt to add 2 packages at once, comma delimited

  1. hammer --username=admin --password=<password> content-view filter rule create --organization=org-example --content-view='filter test' --content-view-filter='test_filter' --name c,d

Will add the package "c,d" to the included rpms

Actual results:

As above

Expected results:

There should be a way of providing more than 1 rpm at a time to hammer.

Additional info:

This is causing my customer issues, because having to run hammer several
hundred times to add a list of packages has significant overhead, and
taking a long time to complete.


Related issues

Related to Katello - Bug #15537: [Sat6] allow multiple rpms to be added via hammer content-view filter rule createClosed2016-06-28

Associated revisions

Revision ad75723f (diff)
Added by Andrew Kofink almost 3 years ago

Fixes #15536 - Allow rpm names in new filter rule (#6157)

This allows an array of package or package group name as well as a
single name to be specified with the `:name` parameter when
creating a content view filter rule.

History

#1 Updated by Andrew Kofink almost 3 years ago

  • Category changed from Hammer to API

#2 Updated by Andrew Kofink almost 3 years ago

  • Related to Bug #15537: [Sat6] allow multiple rpms to be added via hammer content-view filter rule create added

#3 Updated by Andrew Kofink almost 3 years ago

  • Subject changed from [Sat6] allow multiple rpms to be added via hammer content-view filter rule create to [Sat6] allow multiple rpms to be added via content-view filter rule create API endpoint

#4 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6157 added

#5 Updated by The Foreman Bot almost 3 years ago

  • Assignee set to Andrew Kofink

#6 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 162
  • Difficulty set to medium

#7 Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF