Project

General

Profile

Bug #15557

Unable to view filtered errata to add to a content view

Added by Brad Buckingham almost 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1346428
Description of problem:
When trying to add errata to a content view through a filter, you are unable to see the errata. Upon opening the browser's console, you can see that there as a 500 ISE for the GET request.

Version-Release number of selected component (if applicable):
Satellite 6.2 Beta Snap 15.2

How reproducible:
Always

Steps to Reproduce:
1. Create a content view with at least one repository hosting errata.
2. Create a new errata filter.
3. Go to add tab (if not already presented with the errata add view)

Actual results:
No errata seen. Instead a constant loading icon is shown, also a 500 ISE is present in the web console. See attached screenshot and foreman debug output.

Expected results:
The errata is visible and no errors are shown in the web console.

Associated revisions

Revision cc5f43d2 (diff)
Added by Brad Buckingham almost 3 years ago

fixes #15557 - errata: flatten array containing errata uuids

This commit is to address the following error observed on production
installations when viewing the list of errata to add to a content
view errata filter:

2016-06-30 12:43:15 [app] [E] PG::Error: ERROR: syntax error at
or near "," | LINE 1: ...7,11,12,10,8,6))) AND "katello_errata"."uuid" IN | (, , 'a02aa... | ^

The error is due to how the list of UUIDs was generated.
Before, the list may look like:

[["05d5a68a-134c-402b-8221-fb279e42b607",
"36e329c7-0054-4637-8aab-cf5d062b5274",
"7c12381a-c3ac-463f-8b8b-7667423be807",
"9524f7e7-2a1e-4eb1-aa5c-8d418caf000a"], [], []]

After, the list would look like:

["05d5a68a-134c-402b-8221-fb279e42b607",
"36e329c7-0054-4637-8aab-cf5d062b5274",
"7c12381a-c3ac-463f-8b8b-7667423be807",
"9524f7e7-2a1e-4eb1-aa5c-8d418caf000a"]

Revision bae359a2
Added by Brad Buckingham almost 3 years ago

Merge pull request #6159 from bbuckingham/issue-15557

fixes #15557 - errata: flatten array containing errata uuids

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Brad Buckingham
  • Pull request https://github.com/Katello/katello/pull/6159 added

#2 Updated by Brad Buckingham almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

Also available in: Atom PDF