Project

General

Profile

Bug #15558

Katello 2.4 to 3.0 upgrade fails, db:migrate error and update_subscription_facet_backend_data failed

Added by Dylan Baars over 2 years ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
hard
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hi,

I've received the following errors upgrading to 3.0 -

Upgrade Step: fix_pulp_httpd_conf...
Upgrade Step: start_httpd...
Upgrade Step: start_qpidd...
Upgrade Step: start_pulp...
Upgrade Step: migrate_candlepin...
Upgrade Step: start_tomcat...
Upgrade Step: fix_katello_settings_file...
Upgrade Step: migrate_foreman...
Upgrade Step: remove_nodes_distributors...
Upgrade Step: Running installer...
Installing --- /etc/httpd/conf.d/25-puppet.confatell2015-12-08 14 [99%] [........................................................................................................................................................ /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
/Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
Installing Done [100%] [.........................................................................................................................................................]
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/foreman-installer/katello.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: import_package_groups (this may take a while) ...
Upgrade Step: import_rpms (this may take a while) ...
Upgrade Step: import_distributions (this may take a while) ...
Upgrade Step: import_puppet_modules (this may take a while) ...
Upgrade Step: import_subscriptions (this may take a while) ...
Upgrade Step: elasticsearch_message...
Elasticsearch has been removed as a dependency. The database files can be removed manually with #rm -rf /var/lib/elasticsearch. Some packages are no longer needed and can be removed: #rpm -e ruby193-rubygem-tire tfm-rubygem-tire elasticsearch sigar-java sigar snappy-java lucene4-contrib lucene4
Upgrade Step: add_export_distributor (this may take a while) ...
Upgrade Step: remove_docker_v1_content (this may take a while) ...
Upgrade Step: update_puppet_repository_distributors (this may take a while) ...
Upgrade Step: update_subscription_facet_backend_data (this may take a while) ...
Upgrade step update_subscription_facet_backend_data failed. Check logs for more information.
[root@wellkatello ~]#

Attached /var/log/foreman-installer/katello.log, I also ran "/usr/sbin/foreman-rake db:migrate --trace" - output attached as "db_migrate_with_trace.txt"

db_migrate_with_trace.txt db_migrate_with_trace.txt 11.1 KB Dylan Baars, 07/01/2016 01:11 AM
katello.log katello.log 1.32 MB Dylan Baars, 07/01/2016 01:11 AM

Related issues

Is duplicate of Katello - Bug #15269: Katello 3.0 RC5 Upgrade fail Closed2016-06-02

History

#1 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 168 to 171

#2 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) deleted (171)

#3 Updated by Justin Sherrill over 2 years ago

  • Status changed from New to Duplicate
  • Assignee set to Eric Helms
  • Difficulty set to hard

#4 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 166

#5 Updated by Justin Sherrill over 2 years ago

  • Is duplicate of Bug #15269: Katello 3.0 RC5 Upgrade fail added

Also available in: Atom PDF