Project

General

Profile

Bug #15592

Remove Ruby 1.9.3 support

Added by Andrew Kofink over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Ruby < 2.0 no longer receives security updates, so it could be insecure.

We're removing support for Ruby < 2.0 in hammer-cli-foreman, and hammer-cli.


Related issues

Related to Hammer CLI - Bug #15595: Remove Ruby 1.9.3 support from Jenkins for hammer-cli-foremanResolved2016-07-06
Related to Katello - Bug #15593: Remove Ruby 1.9.3 support from hammer-cli-katello Travis testsClosed2016-07-06
Blocked by Packaging - Bug #15594: Use Ruby 2.0 on Ubuntu/trusty for hammer packagesClosed2016-07-06

History

#1 Updated by Michael Moll over 2 years ago

  • Blocked by Bug #15594: Use Ruby 2.0 on Ubuntu/trusty for hammer packages added

#2 Updated by Andrew Kofink over 2 years ago

  • Related to Bug #15595: Remove Ruby 1.9.3 support from Jenkins for hammer-cli-foreman added

#3 Updated by Andrew Kofink over 2 years ago

  • Related to Bug #15593: Remove Ruby 1.9.3 support from hammer-cli-katello Travis tests added

#4 Updated by Tomáš Strachota about 2 years ago

  • Status changed from New to Closed

Support for ruby < 2.0 has been removed.

Also available in: Atom PDF