Project

General

Profile

Bug #15593

Remove Ruby 1.9.3 support from hammer-cli-katello Travis tests

Added by Andrew Kofink about 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Ruby < 2.0 no longer receives security updates, so it could be insecure.

We're removing support for Ruby < 2.0 in hammer-cli-katello.


Related issues

Related to Hammer CLI - Bug #15592: Remove Ruby 1.9.3 supportClosed2016-07-06
Blocks Katello - Bug #15589: Remove `hammer content-host update` - New command is `hammer host update`Closed2016-07-06

Associated revisions

Revision 7b95d443 (diff)
Added by Andrew Kofink about 3 years ago

Fixes #15593 - Remove Ruby 1.9.3 from Travis

Revision 3a50a56e
Added by Andrew Kofink about 3 years ago

Merge pull request #417 from akofink/15593

Fixes #15593 - Remove Ruby 1.9.3 from Travis

History

#1 Updated by Andrew Kofink about 3 years ago

  • Assignee set to Andrew Kofink

#2 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/417 added

#3 Updated by Andrew Kofink about 3 years ago

  • Blocks Bug #15589: Remove `hammer content-host update` - New command is `hammer host update` added

#4 Updated by Andrew Kofink about 3 years ago

  • Subject changed from Remove Ruby 1.9.3 support to Remove Ruby 1.9.3 support from hammer-cli-katello Travis tests

#5 Updated by Andrew Kofink about 3 years ago

  • Related to Bug #15592: Remove Ruby 1.9.3 support added

#6 Updated by Andrew Kofink about 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) set to 162

Also available in: Atom PDF