Project

General

Profile

Bug #15629

Validation errors for Domain and OS Parameters tab not showing

Added by Ivan Necas about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1353104
Description of problem:
When you input invalid values into 'Name' and 'Value' fields for new Domain or Operating System entity and push submit button, parameter entry just disappear without any error shown

How reproducible:
Always

Steps to Reproduce:
1. Create new Domain entity
2. Open it and go to 'Parameters' tab
3. Push '+Add Parameter' button
4. Input invalid values (longer than 256 characters) in both fields
5. Push 'Submit' button

Actual results:
Parameter entry is disappeared and no error is shown

Expected results:
Proper (just usual one) error is shown

This seems to be caused by #13164, where we use the authorized scope
in the form, which means we loose the data about params, that the user sent
when there is a validation error.


Related issues

Related to Foreman - Bug #13164: view_params is missingClosed2016-01-12

Associated revisions

Revision 2432eb5c (diff)
Added by Ori Rabin about 4 years ago

Fixes #15629 - parameters form shows new parameters after error

History

#1 Updated by Ivan Necas about 4 years ago

  • Description updated (diff)
  • Category changed from Web Interface to Parameters

#2 Updated by Ivan Necas about 4 years ago

  • Related to Bug #13164: view_params is missing added

#3 Updated by Dominic Cleal about 4 years ago

  • Subject changed from Validation for Domain and OS Parameters tab stopped to work to Validation errors for Domain and OS Parameters tab not showing
  • Category changed from Parameters to Web Interface
  • Legacy Backlogs Release (now unused) set to 160

#4 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Ori Rabin
  • Pull request https://github.com/theforeman/foreman/pull/3636 added

#5 Updated by Ori Rabin about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF