Fog Openstack version should require at least version 0.1.7 to ensure compatibility with Openstack Liberty
Due to changes in Openstack, the Compute API in Liberty (and maybe other APIs) are no longer forgiving for empty values.
See the following commit: https://github.com/fog/fog-openstack/commit/13bfc96ba646c65487c8a619ee84ad5f6268e702
This totally breaks stuff like boot from volume.
Fixes #15681 - Upgrade Fog Openstack to at least version 0.1.7
This is need to ensure compatibility with Openstack Liberty and above.
The API since Liberty is less forgiving about empty parameters.
#4 Updated by Imri Zvik about 5 years ago
Dominic Cleal wrote:
The pinning of fog-core to 1.36.0 currently prevents the ~> 0.1 matcher from matching 0.1.7. If fog-core is updated to over 1.40 (either specifically, or unpinned) then we'll automatically inherit a newer version of fog-openstack too.
btw, another thing to note is that nothing ensures you will get the latest version of 0.1 - see https://github.com/bundler/bundler/issues/3089#issuecomment-48533609 for example.
Therefore, it is probably a good idea to change the requirement anyway.