Project

General

Profile

Bug #15702

katello disconnected instructions fail to work due to vhost configuration

Added by Josh Roys almost 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Documentation
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The instructions at http://www.katello.org/docs/3.0/user_guide/disconnected/ fail to work as the first vhost, 05-foreman.conf, takes precedence over the remaining vhosts if the ServerName doesn't match. My current work-around is to use http://default/export/ (taking advantage of the puppetlabs apache default_vhost) and to place the exported content in /var/www/html/export/

Associated revisions

Revision 3913669a (diff)
Added by Chris Duryee over 2 years ago

Fixes #15702: typo in path name (#287)

The ISS docs mention `/var/www/pub/` as the exposed path which is
incorrect, it should be `/var/www/html/pub/`.

A few other docs fixups were made as well with this patch.

History

#1 Updated by Dominic Cleal almost 3 years ago

  • Project changed from Installer to Katello

#2 Updated by Justin Sherrill almost 3 years ago

  • Assignee set to Chris Duryee

yeah /pub is not exposed over http. We probably need to either update the vhost config, or use a different path

#3 Updated by Justin Sherrill almost 3 years ago

  • Status changed from New to Need more information

actually after testing, /pub is exposed via http.

What issue are you seeing exactly Josh? Is accessing /pub over http not working?

#4 Updated by Justin Sherrill almost 3 years ago

  • Status changed from Need more information to Assigned

Ahhh the issue is the katello.org page documents using:

/var/www/pub

while it should document using

/var/www/html/pub/

#5 Updated by The Foreman Bot almost 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello.org/pull/287 added

#6 Updated by Justin Sherrill almost 3 years ago

  • Category set to Documentation
  • Legacy Backlogs Release (now unused) set to 143
  • Difficulty set to trivial

#7 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 143 to 184

#8 Updated by Chris Duryee over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF