Project

General

Profile

Bug #15809

rhel client setup with shortname that is subcription-manager subscribed to satellite causes backend problems

Added by Brad Buckingham almost 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1158139
Description of problem:

capsule and content name shortname and long name mismatch causing errors.
appears to be the result of shortname that comes in from subscription manager to content host.
Actions::Katello::CapsuleContent::AddLifecycleEnvironment
+- Actions::Katello::CapsuleContent::AddRepository
Input:
--- {}
ActiveRecord::RecordNotFound (ActiveRecord::RecordNotFound)
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/relation/finder_methods.rb:129:in `first!'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/katello/capsule_content.rb:44:in `consumer_uuid'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/lib/actions/katello/capsule_content/add_repository.rb:24:in `plan'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:398:in `block (3 levels) in execute_plan'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in `pass'
Version-Release number of selected component (if applicable):
How reproducible:
Steps to Reproduce:
1.
2.
3.
Actual results:
Expected results:
Additional info:
This seems to be caused by the fact that the capsule is named 'x123.acme.com', while the content host
that represents the registered system is named 'x123': renaming the content host to 'x123.acme.com'
should get us moving forward, as the names of the capsule and the content host, and adding the env to the capsule should start working again.
Also if customer is setup for shortname they can subscribe with full FQDN as such.
in subscription manager's help
--name=SYSTEMNAME     name of the system to register, defaults to the
hostname
I believe the general right recommendation here is for customers to not use shortname configuration.

Related issues

Blocks Katello - Tracker #15825: Sprint 1 : Content-FocusedNew2016-07-24

History

#1 Updated by Brad Buckingham almost 6 years ago

#2 Updated by Justin Sherrill almost 6 years ago

  • Subject changed from rhel client setup with shortname that is subcription-manager subscribed to satellite causes backend problems to rhel client setup with shortname that is subcription-manager subscribed to satellite causes backend problems
  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF