Project

General

Profile

Bug #15810

Providing invalid URL for a custom repo, WebUI raises exception but stores it

Added by Brad Buckingham almost 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1262313
Description of problem:
Having a custom product for a custom repository and updating URL of the repo: if one provides an invalid URL (say http://username:password@@example.com/repo), WebUI complains about the invalid URL but it stores the invalid URL.

Consequent attempt to synchronize the repository fails with obscure / unexpected error.
This bug is dangerous especially due to the fact WebUI convicts the user it detected URL invalid and rejected the change. So the user is convicted previous valid URL is used.
Version-Release number of selected component (if applicable):
Sat 6.1.1 / foreman-1.7.2.34-1.el7sat.noarch
How reproducible:
100%
Steps to Reproduce:
1. Create a custom product and a custom repo
2. Provide some valid URL there
3. Try to sync it
4. Try to update the URL to some invalid one.
5. WebUI raises some exception, so click to Cancel
6a Check the URL of the repo
6b Try to sync the repo.
(6a+6b can be done in any order)
Actual results:
6a: the URL is updated to the invalid one
6b: repo sync fails with "Importer indicated invalid response" pulp error (details depends on how you malform the URL / if you use credentials there etc.)
Expected results:
6a: original URL is stored there
6b: repo sync succeeds (most probably with no update done due to recent sync done)
Additional info:

Related issues

Blocks Katello - Tracker #15825: Sprint 1 : Content-FocusedNew2016-07-24

History

#1 Updated by Brad Buckingham almost 6 years ago

#2 Updated by Brad Buckingham almost 6 years ago

  • Subject changed from Providing invalid URL for a custom repo, WebUI raises exception but stores it to Providing invalid URL for a custom repo, WebUI raises exception but stores it
  • Status changed from New to Rejected

After further testing, this issue appears to be resolved.

#3 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF