Project

General

Profile

Bug #15830

Hammer doesn't handle removal of required :organization_id param on content_view and lifecycle_environment

Added by Andrew Kofink almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
hard
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Figure out a way to resolve content_view and lifecycle_environment IDs from organization options at the unscoped top level (i.e. --organization-id, --organization, --organization-label)


Related issues

Has duplicate Katello - Bug #15733: hammer content-view version list ignores --organization optionsRejected2016-07-19
Has duplicate Katello - Feature #15730: Determine --lifecycle-environment-organization-id option from --organizationRejected2016-07-19
Has duplicate Katello - Bug #15690: Handle API removal of organization_id as a required param for content_view and lifecycle_environment #indexRejected2016-07-14

Associated revisions

Revision e0bea267 (diff)
Added by Andrew Kofink almost 3 years ago

Fixes #15830 - Handle non-required org options (#428)

History

#1 Updated by Andrew Kofink almost 3 years ago

  • Is duplicate of Bug #15733: hammer content-view version list ignores --organization options added

#2 Updated by Andrew Kofink almost 3 years ago

  • Status changed from New to Rejected

Closing due to duplicate bug.

#3 Updated by Andrew Kofink almost 3 years ago

  • Status changed from Rejected to New

#4 Updated by Andrew Kofink almost 3 years ago

  • Is duplicate of deleted (Bug #15733: hammer content-view version list ignores --organization options)

#5 Updated by Andrew Kofink almost 3 years ago

  • Has duplicate Bug #15733: hammer content-view version list ignores --organization options added

#6 Updated by Andrew Kofink almost 3 years ago

  • Has duplicate Feature #15730: Determine --lifecycle-environment-organization-id option from --organization added

#7 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 162
  • Difficulty set to hard

#8 Updated by Andrew Kofink almost 3 years ago

  • Has duplicate Bug #15690: Handle API removal of organization_id as a required param for content_view and lifecycle_environment #index added

#9 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/428 added

#10 Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by David Davis almost 3 years ago

  • Bugzilla link set to 1356906

Also available in: Atom PDF