Project

General

Profile

Feature #15876

Send request and session ids to foreman-proxy as HTTP headers

Added by Lukas Zapletal about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Logging
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

We can pass them into foreman-proxy logs and correlate them with request/session and perhaps transaction id (generate one for each individual orchestration run).


Related issues

Related to Foreman - Feature #15863: Log request IDs (tagged logging) in production.logClosed2016-07-27
Related to Smart Proxy - Feature #15877: Print session/request id in foreman-proxy logsDuplicate2016-07-28
Is duplicate of Foreman - Feature #10982: Add logging to smart proxy requests (ProxyAPI)Closed2015-07-02

History

#1 Updated by Lukas Zapletal about 5 years ago

  • Related to Feature #15863: Log request IDs (tagged logging) in production.log added

#2 Updated by Dominic Cleal about 5 years ago

The pull request associated with #10982 does this.

#3 Updated by Lukas Zapletal about 5 years ago

  • Related to Feature #15877: Print session/request id in foreman-proxy logs added

#4 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Feature #10982: Add logging to smart proxy requests (ProxyAPI) added

#5 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF