Project

General

Profile

Feature #15884

Foreman API: smart proxy, identify action

Added by Zhechka Toteva about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
BMC
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi

We have seen that the smart proxy library (lib/proxy_api/bmc.rb) contains functionality for the identification in the chassis. Unfortunately this functionality is not exposed in the Foreman API. (We use version 1.11.2).

Would it be possible this functionality to be included in the API?

Our use case is relatively straightforward: Once this functionality is available, the procurement team will create a CLI using this method of the Foreman API for blinking from a distance the LED on the chassis. It is going to save them a lot of verification time and will certainly reduce the human factor errors.

Best regards
Zhechka
on behalf of the Config team at CERN

smart proxies (see /bmc/:host/chassis/identify/:action)


Related issues

Is duplicate of Foreman - Feature #8524: Enable/disable UID led/lamp/light via BMCNew2014-11-26

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Feature #8524: Enable/disable UID led/lamp/light via BMC added

#2 Updated by Dominic Cleal about 5 years ago

  • Category set to BMC
  • Status changed from New to Duplicate

Thanks for the report, this feature is tracked under ticket #8524.

Also available in: Atom PDF