Project

General

Profile

Bug #15904

Installer upgrade should only perform errata/gpg steps once

Added by Stephen Benjamin almost 3 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1264597
With every update of Satellite 6 we are asking users to run:

katello-installer --upgrade

With each execution we are forced to re-run the errata_import and gpg_urls steps:

"""
Step: errata_import (this may take a while) ...
Upgrade Step: update_gpg_urls (this may take a while) ...
"""

on larger installations this can actually take hours to complete.

This is a significant amount of downtime for a production instance of Satellite 6.

There needs to be a way to mark this step as complete once finished and only run it once.


Related issues

Is duplicate of Katello - Bug #16869: Installer upgrade should only perform errata/gpg/rpm steps onceClosed2016-10-11

History

#1 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to medium

#2 Updated by Ivan Necas over 2 years ago

isn't this a duplicate of #16869?

#3 Updated by Stephen Benjamin over 2 years ago

  • Status changed from New to Duplicate

It is

#4 Updated by Stephen Benjamin over 2 years ago

  • Is duplicate of Bug #16869: Installer upgrade should only perform errata/gpg/rpm steps once added

Also available in: Atom PDF