Project

General

Profile

Bug #15967

foreman-debug collects just few mongo task statuses

Added by Zach Huntington-Meath almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
foreman-debug
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1329980
Description of problem:
foreman-debug collects mongo collection task_status (worth used for investigating pulp task issues). BUT the command in

/usr/share/foreman/script/foreman-debug.d/katello-debug.sh

collects only 20 rows of that table/collection, due to the default (non-clever) limitation of mongo. Please collect all the rows, by replacing:

add_cmd "mongo pulp_database --eval \"db.task_status.find().pretty().shellPrint()\"" "mongo-task_status"

by:

add_cmd "mongo pulp_database --eval \"DBQuery.shellBatchSize = 100000;; db.task_status.find().pretty().shellPrint()\"" "mongo-task_status"

(i.e. add "DBQuery.shellBatchSize = 100000;" there)

Version-Release number of selected component (if applicable):
katello-debug-2.2.0.19-1.el7sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. foreman-debug
2. unpack collected f-d
3. check mongo-task_status

Actual results:
mongo-task_status has just 20 entries and the file ends with:

Type "it" for more

Expected results:
mongo-task_status to have all entries

Additional info:
Since the table/collection might be quite big and collecting it might not be necessary, isn't it better to collect e.g. all tasks from past one week or so? Or additionally older not finished tasks?

Associated revisions

Revision 13527899 (diff)
Added by Amit Upadhye almost 2 years ago

Fixes #15967 - collect recent 200 tasks

History

#1 Updated by Dominic Cleal almost 3 years ago

  • Project changed from Foreman to Katello
  • Category deleted (foreman-debug)

#2 Updated by Lukas Zapletal almost 3 years ago

  • Assignee deleted (Lukas Zapletal)

I have no idea what these tasks are for. Someone from Katello please do the patch.

#3 Updated by Justin Sherrill almost 3 years ago

ideally we would just collect a weeks worth or something, not all

#4 Updated by Justin Sherrill almost 3 years ago

  • Category set to Tooling
  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to easy

#5 Updated by Eric Helms over 2 years ago

  • Category changed from Tooling to foreman-debug

#6 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-packaging/pull/478 added

#7 Updated by The Foreman Bot almost 2 years ago

  • Pull request https://github.com/Katello/katello-packaging/pull/554 added

#8 Updated by Amit Upadhye over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF