Project

General

Profile

Bug #15978

hammer host-collection package/package-group/erratum commands use the old systems_controller

Added by Andrew Kofink about 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host Collections
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

These three subcommands use the non-existent systems_controller. They should be migrated to use the hosts_controller.

hammer host-collection package install/update/remove
hammer host-collection package-group install/update/remove
hammer host-collection erratum install

This is due to host unification.


Related issues

Is duplicate of Katello - Bug #16158: hammer host-collection package * actions brokenDuplicate2016-08-17
Has duplicate Katello - Bug #17769: hammer host-collection package install : throw exception (404 Resource Not Found)Resolved2016-12-19
Has duplicate Katello - Bug #17768: hammer host-collection erratum install : throw exception (404 Resource Not Found)Resolved2016-12-19

Associated revisions

Revision cb912dfa (diff)
Added by Andrew Kofink almost 3 years ago

Fixes #15978 - Remove katello api base url for... (#6331)

for host bulk actions

Revision 71e64a8f (diff)
Added by Andrew Kofink almost 3 years ago

Fixes #15978 - Fix host-collection content cmds (#452)

host-collection [package|package-group|erratum] [install|update|remove]

This change is needed due to host unification. The api changes slightly
to ensure bulk host operations go through the Foreman API rather than
the Katello api.

History

#1 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Justin Sherrill about 3 years ago

  • Category changed from Hammer to Host Collections

#3 Updated by Justin Sherrill about 3 years ago

  • Is duplicate of Bug #16158: hammer host-collection package * actions broken added

#4 Updated by Justin Sherrill about 3 years ago

  • Status changed from New to Duplicate

#5 Updated by Justin Sherrill almost 3 years ago

  • Status changed from Duplicate to New

#6 Updated by Andrew Kofink almost 3 years ago

  • Target version set to 126

#7 Updated by Brad Buckingham almost 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Andrew Kofink
  • Bugzilla link set to 1372372

#8 Updated by The Foreman Bot almost 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Legacy Backlogs Release (now unused) deleted (114)
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/452 added

#9 Updated by The Foreman Bot almost 3 years ago

  • Pull request https://github.com/Katello/katello/pull/6331 added

#10 Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by Eric Helms almost 3 years ago

  • Status changed from Closed to Ready For Testing
  • Legacy Backlogs Release (now unused) set to 162

#12 Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed

#13 Updated by Andrew Kofink over 2 years ago

  • Has duplicate Bug #17769: hammer host-collection package install : throw exception (404 Resource Not Found) added

#14 Updated by Andrew Kofink over 2 years ago

  • Has duplicate Bug #17768: hammer host-collection erratum install : throw exception (404 Resource Not Found) added

Also available in: Atom PDF