Project

General

Profile

Bug #16028

Upgrades fail if a proxy is set on the system

Added by Partha Aji about 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1365542
Description of problem:

We're seeing 6.2 systems where tomcat fails to start if $https_proxy is set.

Version-Release number of selected component (if applicable):

6.2.0

How reproducible:

100%

Steps to Reproduce:
1. On a 6.1 system, set $https_proxy
2. Perform upgrade

Actual results:

Installer fails with:

[ INFO 2016-08-03 23:18:08 main] Upgrade Step: start_tomcat...
[ERROR 2016-08-03 23:20:10 main] Redirecting to /bin/systemctl start tomcat.service

Some services failed to start: tomcat

Expected results:

Upgrade ignores proxy and succeeds.

Additional info:

I found this commit:

https://github.com/Katello/puppet-service_wait/commit/c641a1112aea1e4ffd01a5d39aff0f4c5d32fb4f

Looks like we need to make the same change here:

https://github.com/Katello/katello-packaging/blob/b56fc78b6144ccbb7581944f705514da70ef53c5/katello/service-wait#L46

Associated revisions

Revision 19b89793 (diff)
Added by David Davis about 3 years ago

Fixes #16028 - Ignoring proxy when pinging services (#267)

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-packaging/pull/267 added

#2 Updated by Anonymous about 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) set to 143
  • Difficulty set to easy

Also available in: Atom PDF