Project

General

Profile

Feature #16029

Unable to delete/remove Red Hat provided repositories, using process that is similar deleting a custom repository

Added by Andrew Kofink almost 6 years ago. Updated 10 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1152672
Description of problem:

Unable to delete/remove Red Hat provided repositories, it says "You can not remove this repository because it is a Red Hat repository"
Version-Release number of selected component (if applicable):
Red Hat Satellite v 6.0.4
How reproducible:
Always
Steps to Reproduce:
1. Sync couple of repositories on Red Hat Satellite v 6 server
2. Go to Product -> Click on "Red Hat Enterprise Linux Server" -> Click on the repository to delete
3. There is no option to remove repository, the question mark "?" sign says "You can not remove this repository because it is a Red Hat repository"
Also not able to remove repository using hammer command :
  1. hammer repository delete --id 6
    [Foreman] username: admin
    [Foreman] password for admin:
    Could not delete the Repository:
    Red Hat repositories cannot be manipulated.
Expected results:
There should be option to delete/remove Red Hat provided repositories.
Additional info:

Related issues

Is duplicate of Katello - Feature #32800: support deleting RH repos from the repositories detailsClosed

History

#1 Updated by Andrew Kofink almost 6 years ago

#2 Updated by Andrew Kofink almost 6 years ago

#3 Updated by Justin Sherrill almost 6 years ago

  • Subject changed from Unable to delete/remove Red Hat provided repositories, using process that is similar deleting a custom repository to Unable to delete/remove Red Hat provided repositories, using process that is similar deleting a custom repository
  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to medium

#4 Updated by Justin Sherrill 10 months ago

  • Triaged set to No
  • Status changed from New to Duplicate

#5 Updated by Justin Sherrill 10 months ago

  • Is duplicate of Feature #32800: support deleting RH repos from the repositories details added

#6 Updated by Justin Sherrill 10 months ago

  • Triaged changed from No to Yes
  • Target version changed from Katello Backlog to Katello Recycle Bin

Also available in: Atom PDF