Project

General

Profile

Bug #16033

Search functionality stop to work after selecting Activation Key Association tab

Added by Walden Raines almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1342057
Description of problem:
For example, I have one activation key created. That activation key doesn't have any additional fields filled or any other entities attached except required one (so only 'name' field has value). I can search for that activation key without any problem, but once I select 'Associations'->'Content Hosts' tab, screen with activation keys list change color (turn grey) and search functionality doesn't work (empty list is returned if you try to look for any entity).

Same behavior is for activation key that has content host attached to it.

Version-Release number of selected component (if applicable):
6.2 SNAP 14

How reproducible:
Always

Steps to Reproduce:
1. Create new activation key
2. Open that new entity
3. Select 'Associations'->'Content Hosts' tab
4. Try to test search functionality

Actual results:
Search doesn't work

Expected results:
Search works fine

Additional info:

Associated revisions

Revision 8ec1a101 (diff)
Added by Walden Raines almost 3 years ago

Fixes #16033: set search key for AK CH table.

We need to set the search key for the activation key content host
table in order for the search to work properly in the parent table.
Also fixed a couple of references to the parent table that should have
been references to the details table.

http://projects.theforeman.org/issues/16033

Revision 5894e90c
Added by Walden Raines almost 3 years ago

Merge pull request #6237 from waldenraines/16033

Fixes #16033: set search key for AK CH table.

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6237 added

#2 Updated by Walden Raines almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 162
  • Difficulty set to easy

Also available in: Atom PDF