Project

General

Profile

Bug #16045

Nested hostgroup does not provide a option to override puppet classes coming from parent hostgroup

Added by Daniel Lobato Garcia about 2 years ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Daniel
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1294074
1. Proposed title of this feature request

When we create a nested hostgroup it does inherit all puppet classes of parent host group, request to add option so it would be possible to select which classes to inherit from parent host group.

2. Who is the customer behind the request?

3. What is the nature and description of the request?

There is no way to override puppet classes coming from parent host group when creating new nested host group. Need a way to do this.

4. Why does the customer need this? (List the business requirements here)

To select specific classes from parent hostgroup when creating nested host group.

5. How would the customer like to achieve this? (List the functional requirements here)

Having an option to override puppet class selection for nested host groups.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

Confirming if we can override puppet classes coming from parent host group.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

No.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?

No.

9. Is the sales team involved in this request and do they have any additional input?

No.

10. List any affected packages or components.

Unknown.

11. Would the customer be able to assist in testing this functionality if implemented?

Yes.


Related issues

Is duplicate of Foreman - Feature #6416: Ability to remove an included puppet class from a nested host group and a hostNew2014-06-27

History

#1 Updated by Daniel Lobato Garcia about 2 years ago

  • Target version set to 117

#2 Updated by Dominic Cleal about 2 years ago

  • Is duplicate of Feature #6416: Ability to remove an included puppet class from a nested host group and a host added

#3 Updated by Dominic Cleal about 2 years ago

  • Status changed from New to Duplicate

I think this is the same request as #6416, which describes removal of inherited classes in either a group or individual host.

#4 Updated by Tomer Brisker 6 months ago

  • Description updated (diff)

Also available in: Atom PDF