Project

General

Profile

Bug #16064

Pulp storage error

Added by Brian Shaw almost 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When I look at the Smart Proxy page it displays, "Error retrieving Pulp storage".
Both our master and capsules are running Katello 3.1rc1 on RHEL 7.
Attached is a screenshot with the error highlighted in yellow.

Brian

pulp storage error.png View pulp storage error.png 34 KB Screenshot of error Brian Shaw, 08/11/2016 09:00 AM
Pulp%20storage%20error

Related issues

Is duplicate of Katello - Bug #16267: Pulp disk usage not displaying in Capsule UI pageDuplicate2016-08-24

Associated revisions

Revision 2bb06e19 (diff)
Added by John Mitsch over 2 years ago

Fixes #16064 - Settings are not loading correctly for capsules

Pulp node settings are not loading properly on a capsule. This will
use pulp settings as a fallback, and may help to remove pulp node
settings from foreman proxy as pulp nodes have been removed from
capsules.

History

#1 Updated by Dominic Cleal almost 3 years ago

  • Project changed from Foreman to Katello
  • Category deleted (Smart proxies)

Unsure if this is Katello the smart-proxy-pulp plugin, if the latter move to Plugins subproject.

#2 Updated by Justin Sherrill almost 3 years ago

  • Status changed from New to Need more information

Any logs in /var/log/foreman/production.log on the katello server or /var/log/foreman-proxy/proxy.log on the capsule?

A foreman-debug from both the katello server and capsule would help.

#3 Updated by Brian Shaw almost 3 years ago

I don't know if this is related, but, when I refreshed the Smart Proxy page I see the following in the capsule log:

E, [2016-08-19T11:34:06.844816 #3208] ERROR -- : undefined method `join' for #<String:0x00000002d0e308> (NoMethodError)
/usr/share/gems/gems/sinatra-1.3.5/lib/sinatra/showexceptions.rb:37:in `rescue in call'
/usr/share/gems/gems/sinatra-1.3.5/lib/sinatra/showexceptions.rb:21:in `call'
/usr/share/gems/gems/sinatra-1.3.5/lib/sinatra/base.rb:124:in `call'
/usr/share/gems/gems/sinatra-1.3.5/lib/sinatra/base.rb:1417:in `block in call'
/usr/share/gems/gems/sinatra-1.3.5/lib/sinatra/base.rb:1499:in `synchronize'
/usr/share/gems/gems/sinatra-1.3.5/lib/sinatra/base.rb:1417:in `call'
/usr/share/gems/gems/rack-1.6.4/lib/rack/urlmap.rb:66:in `block in call'
/usr/share/gems/gems/rack-1.6.4/lib/rack/urlmap.rb:50:in `each'
/usr/share/gems/gems/rack-1.6.4/lib/rack/urlmap.rb:50:in `call'
/usr/share/gems/gems/rack-1.6.4/lib/rack/builder.rb:153:in `call'
/usr/share/gems/gems/rack-1.6.4/lib/rack/handler/webrick.rb:88:in `service'
/usr/share/ruby/webrick/httpserver.rb:138:in `service'
/usr/share/ruby/webrick/httpserver.rb:94:in `run'
/usr/share/ruby/webrick/server.rb:295:in `block in start_thread'

And on the Katello server:

2016-08-19 11:39:44 [app] [I] Started GET "/smart_proxies/10-svllmgxa01-sgstage-local/pulp_storage" for 10.63.48.60 at 2016-08-19 11:39:44 -0400
2016-08-19 11:39:44 [app] [I] Processing by SmartProxiesController#pulp_storage as HTML
2016-08-19 11:39:44 [app] [I] Parameters: {"id"=>"10-svllmgxa01-sgstage-local"}
2016-08-19 11:39:44 [app] [W] Error connecting. Got: ERF50-5345 [Foreman::WrappedException]: Unable to connect ([ProxyAPI::ProxyException]: ERF12-3580 [ProxyAPI::ProxyException]: Unable to detect pulp storage ([RestClient::Inte...)
2016-08-19 11:39:44 [app] [I] Rendered text template (0.0ms)
2016-08-19 11:39:44 [app] [I] Completed 200 OK in 370ms (Views: 0.6ms | ActiveRecord: 3.9ms)

#4 Updated by Justin Sherrill over 2 years ago

  • Has duplicate Bug #16267: Pulp disk usage not displaying in Capsule UI page added

#5 Updated by Justin Sherrill over 2 years ago

  • Status changed from Need more information to Duplicate
  • Legacy Backlogs Release (now unused) set to 166

#6 Updated by John Mitsch over 2 years ago

  • Target version set to 123

#7 Updated by Justin Sherrill over 2 years ago

  • Has duplicate deleted (Bug #16267: Pulp disk usage not displaying in Capsule UI page)

#8 Updated by Justin Sherrill over 2 years ago

  • Is duplicate of Bug #16267: Pulp disk usage not displaying in Capsule UI page added

#9 Updated by Justin Sherrill over 2 years ago

  • Category set to Foreman Proxy Content
  • Status changed from Duplicate to Assigned
  • Assignee set to John Mitsch

#10 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 166 to 162

#11 Updated by John Mitsch over 2 years ago

  • Pull request https://github.com/theforeman/smart_proxy_pulp/pull/8 added

#12 Updated by John Mitsch over 2 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF