Project

General

Profile

Bug #16069

Strange behaviour on "Red Hat Subscription" tab.

Added by Walden Raines over 4 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1366189
Description of problem:

The hyperlink under "Red Hat Subscription" tab is broken.

Version-Release number of selected component (if applicable):

Satellite 6.2

How reproducible:

Always.

Steps to Reproduce:
1. Create a new organization or install a new satellite.
2. Do not import manifest
3. Content > Red Hat repositories.
4. As we have not imported manifest, the page will display a message "No Red Hat products currently exist, please import a manifest here to receive Red Hat content."
5. If you look closely, you will notice that the word "here" is a hyperlink which should take the user on "Manage Manifest" page.
6. Click on hyperlink, and it will take you on "https://<Satellite FQDN>/subscriptions"
7. You will notice the page is blank.

Actual results:
Link takes the user on "https://<Satellite FQDN>/subscriptions". And the page remains blank.

Expected results:
The hyperlink should take the user on "https://<Satellite FQDN>/subscriptions/manifest/import" which is a"Manage Manifest" page.

Additional info:
This issue is not present on Satellite 6.1. It works as expected on satellite 6.1.

Please find attached screenshots for refrence.


Related issues

Is duplicate of Katello - Bug #15803: Opening Red Hat Repositories link without an uploaded manifest provides the user with a dead linkClosed2016-07-22

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6242 added

#2 Updated by Walden Raines over 4 years ago

  • Status changed from Ready For Testing to Duplicate

Duplicate of #15803

#3 Updated by Walden Raines over 4 years ago

  • Is duplicate of Bug #15803: Opening Red Hat Repositories link without an uploaded manifest provides the user with a dead link added

#4 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF