Project

General

Profile

Bug #16089

jquery-rails gem installed by flot-rails

Added by Dominic Cleal almost 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Since #12364 moved jquery from the jquery-rails gem to npm, the jquery-rails gem dependency has remained indirectly because the flot-rails gem depends on it. This should be removed so we can entirely remove the corresponding RPM package.

flot-rails is currently on version 0.0.3, which ships flot 0.8.0. This can be switched to the npm jquery-flot module instead, which currently provides 0.8.3.

Associated revisions

Revision 551407c2 (diff)
Added by Dominic Cleal almost 4 years ago

fixes #16089 - replace flot-rails with npm jquery-flot

Revision ab34e1dc (diff)
Added by Dominic Cleal almost 4 years ago

refs #16089 - replace flot-rails with jquery-flot

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3727 added

#2 Updated by Dominic Cleal almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 160

Also available in: Atom PDF