Project

General

Profile

Bug #16092

Unable to reload VMware datacenters when wrong credentials are passed for the first time

Added by Tomáš Strachota almost 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
Compute resources - VMware
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When creating a new VMware compute resource in the web UI, if users make a typo in the url or credentials and try to load the datacenters, the process fails, displays an error message and hides the [Load Datacenters] button. Unfortunately the datacenter is required and there's now way how to do another attempt to load them with fixed credentials. The only way out is to reload the whole page and fill in the form again.


Related issues

Has duplicate Foreman - Bug #17717: "Load Datacenters" button disappearsDuplicate2016-12-16

Associated revisions

Revision 37885ae9 (diff)
Added by Tomáš Strachota over 2 years ago

Fixes #16092 - Test connection buttons don't disapper on error

History

#1 Updated by Marek Hulán almost 3 years ago

  • Target version changed from 115 to 1.6.0

#2 Updated by Tomáš Strachota almost 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomáš Strachota

#3 Updated by The Foreman Bot over 2 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3794 added

#4 Updated by Marek Hulán over 2 years ago

  • Target version changed from 1.6.0 to 1.5.3

#5 Updated by Anonymous over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Marek Hulán over 2 years ago

  • Legacy Backlogs Release (now unused) set to 189

#7 Updated by Ondřej Pražák over 2 years ago

  • Bugzilla link set to 1364610

#8 Updated by Ondřej Pražák over 2 years ago

  • Bugzilla link changed from 1364610 to 1404985

#9 Updated by Dominic Cleal over 2 years ago

  • Has duplicate Bug #17717: "Load Datacenters" button disappears added

Also available in: Atom PDF