Project

General

Profile

Bug #16098

Unable to cancel content sync.

Added by Brian Shaw almost 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When I click on the cancel button, Katello says "Success: Trying to cancel the task".
However, it never actually gets cancelled.
How can I get it cancelled? We need to be able to sync data for production updates and can't do that while this task is blocking.

Brian

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Project changed from Foreman to Katello

#2 Updated by Justin Sherrill almost 6 years ago

  • Category set to 91
  • Assignee set to John Mitsch

#3 Updated by John Mitsch almost 6 years ago

Brian,

I synced a repo and was able to cancel in both the "processing metadata" step and actual sync stage.

Can you provide some more info so we are better able to reproduce?

What was the repo you were syncing? What part of the sync was it completing when you synced? Any errors in /var/log/messages?

#4 Updated by Brian Shaw almost 6 years ago

John,
Unfortunately, I don't have any log information to provide. However, a rake cleanup command had been provided in another ticket and with some tweaking it was able to kill the tasks. I have not seen this issue occur since then.
Please feel free to close this and if it re-occurs I'll open a new ticket with the log information.

Brian

#5 Updated by John Mitsch almost 6 years ago

  • Status changed from New to Closed

#6 Updated by Justin Sherrill over 5 years ago

  • Tracker changed from Support to Bug
  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF