Project

General

Profile

Bug #16132

When a Discovered Host is converted to a Managed Host the IP address is not changed to fall within the subnet range

Added by Jason Montleon almost 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Discovery plugin
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When booting a host for discovery my understanding is it is using an address from the pool configured in the /etc/dhcp/dhcpd.conf.

When converting the host to discovered though the address is not changed to fall within the range specified for the subnet.

This can lead to conflicts with later discovered hosts having the same IP address specified as an existing host record does.


Related issues

Has duplicate Discovery - Bug #16143: Discovered host IP address is not changed to fall within the subnet rangeReady For Testing

History

#1 Updated by Lukas Zapletal over 2 years ago

  • Status changed from New to Duplicate

Jason, I mis-filed this once again. Since there is ongoing discussion and more rich description, I am closing this one as a dupe of #16143 thanks.

#2 Updated by Lukas Zapletal over 2 years ago

  • Has duplicate Bug #16143: Discovered host IP address is not changed to fall within the subnet range added

Also available in: Atom PDF