Project

General

Profile

Bug #16178

Custom product content published in Library isn't syncing to capsule

Added by John Mitsch almost 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1340686
Description of problem:
Custom yum repository without upstream URL isn't syncing to a capsule automatically. It's possible to trigger synchronization manually via hammer on Satellite. Custom repositories configured with upstream URLs are getting synced automatically

Version-Release number of selected component (if applicable):
6.1.9

How reproducible:
Fully reproducible

Steps to Reproduce:
1. Add Library lifecycle environment to the capsule by running
  1. hammer capsule content add-lifecycle-environment
    1. Create a new product
    2. Add yum repository without specifying an URL
    3. Manually upload rpm files to the repository

Actual results:
New product content isn't synced to the capsule

Expected results:
The content is published and available on the capsule

Additional info:

History

#1 Updated by John Mitsch almost 6 years ago

  • Target version set to 123

#2 Updated by John Mitsch almost 6 years ago

  • Assignee set to John Mitsch

#3 Updated by John Mitsch almost 6 years ago

  • Status changed from New to Rejected

#4 Updated by Justin Sherrill over 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF